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ABSTRACT 

Coral reefs are vital ecosystems that support marine biodiversity and protect shorelines, but face 

increasing threats from human activities. Artificial reefs have emerged as a restoration tool to enhance 

ecological functions and provide habitats for benthic organisms. Turf algae, which are among the first to 

colonize artificial reefs, play a critical role but can inhibit coral recruitment and biodiversity when their 

growth becomes excessive. This study introduces a data-driven methodology for monitoring turf algae 

cover, applied at Damas Beach, East Java, using underwater photography and the ImageJ software. The 

measured turf-algae cover ranged from 12.0% to 33.9% across reef units. Turf algae were higher on 

sediment-free surfaces, consistent with sediment burial likely associated with lower early algal 

colonization. These results demonstrate that an ImageJ-based photo-analysis workflow can quantify turf-

algae cover consistently and support long-term monitoring of artificial reefs. 

Keywords-artificial reef monitoring; imagej software for reef monitoring; long-term reef management; marine 

ecosystem restoration; turf algae quantification 

I. INTRODUCTION  

Coral reefs represent critical coastal ecosystems that play an 
essential role in maintaining marine biodiversity and serving as 
natural barriers against environmental pressures [1]. However, 
they are increasingly threatened by human activities such as 
destructive fishing, pollution, and climate change, leading to 
the degradation of natural reefs. In response, Artificial Reefs 
(ARs) have been widely deployed for ecosystem restoration, 
aiming to restore ecological functions, enhance biodiversity, 
and support benthic communities. ARs help rehabilitate 
damaged coral ecosystems by providing habitats for benthic 

organisms, including turf algae, which are often the first to 
colonize hard substrates such as concrete [2]. 

Although turf algae are essential in the early stages of reef 
colonization, their excessive growth can inhibit coral 
recruitment and reduce biodiversity, challenging the long-term 
success of ARs [3]. Accurately measuring turf algae coverage 
is crucial to understanding their role in reef succession. 
However, reliable and reproducible methods for quantifying 
turf algae cover, especially in southern Java, remain limited. 
This study addresses this gap by developing a data-driven 
methodology to measure turf algae cover on ARs at Damas 
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Beach, using underwater photography and the ImageJ software. 
This approach provides precise quantification while 
minimizing the observer bias common in traditional visual 
assessments [4]. 

This study aimed to establish a robust framework for 
assessing the ecological success of ARs in tropical coastal 
restoration projects [5]. By enhancing turf algae monitoring 
accuracy, this methodology offers a reliable, reproducible tool 
for long-term ecological assessments, contributing to the 
growing body of knowledge in reef restoration and supporting 
future research that incorporates key environmental variables 
influencing turf algae dynamics. Ultimately, this study aims to 
help manage ARs to ensure their success in supporting 
biodiversity and ecosystem recovery.  

II. MATERIALS AND METHODS 

A. Study Site 

Damas Beach, located in Karang Gandu Village, 
Trenggalek Regency, East Java, was chosen for its role in AR 
restoration. This site spans 5.5 hectares along a 2 km coastline. 
In 2017, 25 ARs made from concrete material were installed, 
with 16 remaining intact by 2024, indicating their structural 
integrity and ecological value. Data collection was focused on 
these remaining reef units, as shown in Figure 1 [6]. 

 

 

Fig. 1.  Observation points. 

B. Observation Points and Data Collection 

Underwater images were collected for each AR unit by 
imaging five faces of the cube (top and four lateral faces) and 
collected during 15–17 August 2024. For each face, the camera 
was held parallel to the AR surface (nadir orientation for the 
top face) and kept consistent across units to minimize 
perspective distortion. The camera-to-surface distance was 
adjusted so that the target AR face (nominal 60×60 cm) was 
fully visible in the image with minimal cropping, 
corresponding to an approximate working distance of 0.5–0.8 
m, depending on diver positioning and water conditions. 

A separate scale bar was not placed in each image because 
all AR units had identical fixed dimensions. Spatial calibration 
in ImageJ used the known AR edge length (60 cm) as the 

reference scale. Turf-algae metrics were quantified within a 
manually delineated Region Of Interest (ROI) corresponding to 
the visible boundaries of each AR face, and the percentage of 
cover was computed relative to the ROI of the AR face rather 
than the full image frame. The images were acquired using an 
Olympus Tough TG-6 camera at 4000×3000 pixels (~12 MP) 
in sRGB (24-bit). Acquisition settings were documented from 
EXIF metadata (typical example: f/2.8, 1/320 s, ISO 100, focal 
length 4 mm [25 mm equivalent], flash disabled) to support 
reproducibility. Figure 2 shows an underwater observation. 

 

 

Fig. 2.  Underwater observation: A: Field survey activity around the AR 

structure during data collection; B: AR condition showing the sediment 

accumulation on the seabed. 

C. Turf Algae Quantification Using ImageJ 

ImageJ, a widely used open-source software for precise 
biological analyses [7], was employed to quantify turf algae 
cover on ARs using a cover percentage method. Manual 
digitization within a reef-face ROI (with optional threshold 
overlay for guidance) distinguished turf algae from other 
substrates. Underwater photography integrated with digital 
analysis offers advantages for long-term reef monitoring [8].  

1. Step 1: Set scale per image using the known artificial reef 

(AR) edge length (60 cm) via Analyze → Set Scale (Figure 

3).  

2. Step 2: Define the analyzable reef surface as a ring-shaped 

ROI (outer minus inner), creating two ROIs (Outer and 

Hole) combined in ROI Manager using XOR to generate 

AR_ROI (Figure 3). 

3. Step 3: Apply minimal color/contrast adjustments in 

ImageJ to improve interpretability under green-tinted 

underwater lighting using Image → Adjust → 

Brightness/Contrast, aiding consistent manual delineation 

(no automated filtering) (Figure 4).  

4. Step 4: Optional diagnostic – split RGB channels via 

Image → Color→ Split Channels to enhance visibility, 

especially for strongly green-tinted images. This step 

supports consistent visual interpretation, but is not 

mandatory (Figure 4). 

5. Step 5: Apply an optional threshold overlay in ImageJ 

(Image → Adjust → Threshold) to highlight candidate turf 

patches. Threshold values are adjusted per image for visual 

aid only, not for classification (Figure 5). 
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Fig. 3.  Steps 1-2: Set the image scale using the 60-cm AR edge, then 

define the ring-shaped reef-face ROI (outer minus inner using XOR). 

 

Fig. 4.  Steps 3-4. Adjust brightness/contrast and split RGB channels to 

improve visual interpretation prior to delineation. 

6. Step 6: Manually digitize turf-algae patches within the 

AR_ROI, tracing patches showing filamentous texture and 

a greenish-brown appearance. Each patch is added as a 

separate ROI in ROI Manager. Ambiguous areas are 

excluded. All turf ROIs are merged to create 

TURF_ROI_Final, which is intersected with AR_ROI to 

ensure accuracy (Figure 5). 

7. Step 7: Generate a binary mask for documentation/QC 

using Edit → Selection → Create Mask. Approximately 

15% of images are reprocessed by the same analyst, and a 

subset is digitized by a second analyst to assess 

consistency (Figure 6). 

 

 

Fig. 5.  Steps 5-7. Use Threshold as a visual aid, manually digitize turf-

algae patches, then convert the selection to a binary mask to measure 

Area_Turf. 

Inter-observer agreement was assessed by independently 
reprocessing the same AR faces by two observers following the 
identical ImageJ workflow. Table I shows side-by-side values. 

TABLE I.  INTER-OBSERVER RESULT FOR AR-FACE 
MEASUREMENTS USING THE IMAGEJ PROTOCOL. 

AR_Surface Observer 1 Observer 2 

1_Side_3 876.27 874.52 

2_Upper side 574.07 572.35 

2_Side_3 14.18 13.62 

3_Upper side 512.00 510.97 

6_Upper side 278.29 275.88 

9_Side_1 680.62 675.18 

10_Side_1 634.07 630.90 

10_Side_3 760.32 758.03 

12_Upper side 1350.87 1345.47 

12_Side_2 408.53 406.48 

13_Upper side 1269.20 1266.03 

14_Upper side 1372.47 1360.11 
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Fig. 6.  Example raw and color-corrected underwater images. A-D indicate 

zoomed-in areas, highlighting turf algae and other benthic organisms visible 

on the AR surface. 

D. Calculation of Artificial Reef Exposed Surface Area 

(�����) 

The ARs used in this study were designed to provide 
maximum surface area for colonization. The exposed surface 
area of each reef was calculated by measuring the physical 
dimensions of the reef structure [9], which included the 
column, upper beam, and lower beam areas, as illustrated in 
Figure 7. 

 

 

Fig. 7.  AR calculation. 
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where ����� is the Artificial Reef Exposed Surface Area 
(cm2), ����  is the Column Exposed Surface Area (cm2), 

����is the Upper Frame Beam Exposed Surface Area (cm2), 
����� is the Lower Frame Beam Exposed Surface Area (cm2), 
��  is the exposed column height (cm), ��  is the exposed 
column width (cm), �� is the exposed length of the long upper-
beam segment (60 cm), �� is the exposed length of the short 
upper-beam segment (40 cm), �� is the length of a lower-beam 
side (cm), and ��  is the width of a lower-beam side (cm). 

Surface area was calculated for exposed (non-buried) 
structural faces only; the base/infill and fully buried faces were 
excluded. 

E. Percentage of Turf Algae Coverage 

The percentage of turf algae coverage was calculated using 
the percent cover method, which is a quantitative approach to 
estimating the proportion of an area covered by a particular 
object or organism within the observation field. In this study, 
the observation field consisted of artificial cube-shaped reef 
structures (60×60 cm). Visual images captured within the 
frame were analyzed using the ImageJ software, where the area 
covered by turf algae was identified through image conversion 
and thresholding processes, then measured after scale 
calibration [10]. 

������ �!"�� �
�_$%&'

�_()*+,(- 
� 100  

where �$%&'  is the turf algae area (cm²) measured in ImageJ 

and �()*+,(- is the exposed reef surface area (cm²) of the same 

face. 

F. Artificial Reef Physical Condition 

Sediment burial was assessed for each AR unit by 
measuring sediment thickness (cm) using a representative side 
view. The image scale was set using the known AR dimension 
(60 cm), and the exposed frame height above the sediment 
(�()*+,(-) was measured. Sediment thickness was calculated 

as 01�234
�5� � 60 6 �()*+,(- . Units were classified as Low 

(<10 cm), Medium (10–29 cm), or High (≥30 cm) based on 
burial. Units missing burial data were excluded from analyses. 
Current speed was measured with the Flowatch FL-03 
flowmeter (accuracy ±2%) and water clarity using a standard 
Secchi disk. 

III. RESULTS AND DISCUSSION 

A. Condition of Artificial Reef 

The surface area of ARs plays a key role in supporting turf 
algae colonization; however, sediment accumulation has the 
clearest association with turf algae cover. Reef units with 
minimal sedimentation consistently exhibited higher cover, 
underscoring the importance of sediment-free surfaces for 
optimal algae growth [11]. Figure 8 shows the condition ARs. 
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Fig. 8.  Sediment burial categories (cm) for the 16 AR units: Low (<10 cm, including 0 cm/no sediment) = AR-01, AR-02, AR-03, AR-04, AR-05, AR-13, 
AR-14 (7 units; 43.75%); Medium (10–29 cm) = AR-07, AR-11 (2 units; 12.5%); High (≥30 cm) = AR-06, AR-08, AR-09, AR-10, AR-12, AR-15, AR-16 (7 

units; 43.75%). 

 

Fig. 9.  Turf algae percentage cover across reef units (Reefs 1–16). 

B. Turf Algae Coverage and Variability 

Turf algae coverage ranged from 12.0% to 33.9%, with the 
highest on Reef 1 (3,388 cm²) and the lowest on Reef 7 (863 
cm²), as presented in Table II. �����  varies among units 
because it represents exposed (non-buried) outer faces 
measured from images; sediment burial reduced exposed 
dimensions used in the geometric calculation. This across-reef 
variation is consistent with an association between substrate 
condition in shaping turf algae dynamics. 

TABLE II.  CONDITION OF ARTIFICIAL REEFS 

AR 
Exposed area of AR 

(cm2) 

Turf algae 

cover (cm2) 
Cover % 

Sediment burial 

(cm) 

1 10,000 3,388 33.9 0 (Low) 

2 10,000 2,820 28.2 0 (Low) 

3 10,000 2,217 22.2 0 (Low) 

4 10,000 2,360 23.6 6 (Low) 

5 10,000 2,829 28.3 0 (Low) 

6 6,404 1,137 17.8 30 (High) 

7 7,183 863 12.0 29 (Medium) 

8 5,889 1,060 18.0 45 (High) 

9 6,545 937 14.3 37 (High) 

10 6,877 1,162 16.9 33 (High) 

11 6,080 1,054 17.3 29 (Medium) 

12 6,900 1,152 16.7 33 (High) 

13 10,000 2,363 23.6 0 (Low) 

14 10,000 2,264 22.6 0 (Low) 

15 6,815 972 14.3 35 (High) 

16 10,000 1,407 14.1 34 (High) 

Seven reef units were classified as Low (<10 cm, including 
'no sediment'): Reefs 1, 2, 3, 4, 5, 13, and 14. These units 
exhibited higher turf algae cover, reinforcing the importance of 
cleaner, sediment-free surfaces for optimal colonization [12]. 
This aligns with previous studies showing that minimal 
sediment enhances light penetration and algal attachment 
efficiency [13]. Overall, most units at Damas Beach face 
sedimentation pressure that likely reduces ecological 
performance by limiting benthic growth.  

C. Environmental Factors Influencing Turf Algae Growth 

Turf algae growth is commonly associated with local light 
availability, near-bottom flow, and water quality, with sediment 
acting as a proximate stressor that can reduce the exposed 
substrate usable for algal attachment. Water clarity at the study 
site averaged 3.03±0.31 m (moderate), suggesting that light 
penetration to the reef depth was still possible.  

Current speed averaged 0.13±0.13 m/s (low). These 
conditions may co-vary with sediment settling and water 
clarity, which in turn may relate to benthic communities; 
however, their effects were not tested as causal drivers in this 
study. Figure 9 shows per-reef percent cover (ARs 1–16), 
whereas units exposed to persistent sediment loads exhibit 
lower cover (pattern consistent with prior observations of 
macroalgae-coral dynamics) [14]. 

M M 
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Taken together, these results indicate that managing 
sediment deposition and maintaining adequate light/flow are 
potential management-relevant factors to support turf algae on 
ARs. Excessive sediment can shade the substrate and 
physically hinder filament attachment, suppressing cover even 
where hard surfaces are available [15]. Conversely, on cleaned 
or naturally sediment-free surfaces, colonization proceeds more 
quickly and yields higher cover, aligning with the quantitative 
differences among sediment categories reported here.  

D. Technological Advances in Monitoring Turf Algae 

Integrating underwater photography with ImageJ enables 
precise, repeatable quantification of turf algae on ARs. The 
workflow—calibration, thresholding, and segmentation—
minimizes observer bias and yields consistent percent-cover 
metrics suitable for long-term comparisons across sites and 
seasons [16]. In this study, the same pipeline underpins both 
the per-reef analysis (Figure 3-5) and the sediment-class 
comparison (Figure 7), ensuring that engineering or 
management inferences are grounded in standardized 
measurements rather than subjective estimates. 

Key advantages of this method include: 

 Precision and Repeatability: Standardized digital 
segmentation improves accuracy and auditability over time. 

 High Spatial Resolution: High-throughput frame processing 
supports routine inspections aligned with 
deployment/maintenance cycles. 

 Objectivity: The output integrates directly with substrate 
status (e.g., sediment classes), allowing data-driven 
thresholds for intervention.  

By standardizing monitoring, ImageJ enhances objectivity, 
enables comparisons across reef locations, and ensures 
reproducible long-term results, improving reef health tracking 
and turf algae dynamics for better reef restoration and 
management decisions. 

E. Broader Implications for Reef Restoration and 

Management 

This data-driven workflow links substrate conditions to 
algal outcomes, providing a basis for AR operations. Managers 
can set performance targets for sediment loads and algae cover, 
aligning monitoring with restoration goals [17]. Integrating 
ImageJ-based 2D cover with 3D photogrammetry (SfM) 
extends assessments to surface complexity and microhabitat 
structure [18]. These indicators can be integrated into small-
area conservation programs, strengthening the effectiveness of 
monitoring when resources are limited [19]. 

IV. CONCLUSION 

This study establishes a practical, data-driven workflow for 
monitoring turf algae on ARs using underwater photography 
and ImageJ. Across 16 reef units at Damas Beach, cover 
percentage ranged from 12.0% to 33.9%. Turf algae cover 
differed among sediment categories (Low <10 cm, including no 
sediment; Medium 10-29 cm; High ≥ 30 cm). Maintaining 
sediment-free surfaces may help maintain higher turf algae on 
AR modules. Sediment burial was associated with lower turf 

colonization at an early stage, which is important for 
understanding the dynamics of biota succession in AR, 
including its implications for coral recruitment. Standardizing 
image acquisition and segmentation provides precise, 
repeatable indicators, suitable for routine maintenance and 
long-term assessments. 

Limitations include single-site design, small sample size, 
and lack of seasonal replication and environmental covariates 
(e.g., light, flow). Future studies should expand monitoring 
across seasons and sites, integrate environmental 
measurements, and combine 2D cover with 3D 
photogrammetry to capture surface complexity. Linking these 
to coral recruitment and benthic community trends will help 
identify sediment thresholds for management actions and set 
performance targets for restoration. The ROI and manual 
delineation protocol can be extended to other biota classes 
(CCA, sponges, coral recruits) with clear classification rules 
and inter-observer reliability testing. 
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